Intermittent Failures to Download Telepresence Client

Incident Report for Ambassador

Resolved

The issue with downloads has been resolved. Please contact support@datawire.io if you experience additional issues.
Posted Jul 09, 2025 - 20:37 UTC

Identified

Download links to Telepresence are occasionally failing through https://app.getambassador.io. The issue is actively being fixed.
Posted Jul 03, 2025 - 19:07 UTC